HCL Commerce Personalization Demo #1 — SoFy Environment

Some introduction and details go here

|Step 1 - Review Current Website Content

Open up Emerald Storefront from the SoFy Solution Console link

Review the home hero image and recommend products currently displayed
Click on any recommended product

Add to cart > View full cart

Click on Emerald icon in top right of page

Notice that the home hero image and product recommendations are unchanged
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Step 2 - Create New Home Hero Content

1. Open Management Center from the SoFy Solution Console link
2. Menu > Workspace Management > File > Work on Approved Content
3. Menu > Marketing
4. Verify store showing right side drop down is EmeraldSAS
a. If not, select EmeraldSAS from drop-down menu
Select Content from left menu list
Select HomeHeroContent
a. Edit> Copy
b. Edit > Paste
7. Modify new content
a. Name: HomeHeroContent-Bedroom
b. Text: <div class="MuiGrid-root MuiGrid-container marketing-content
marketing-backgroundImage marketing-heroImage
KitchenHeroContent"><img
src="/EmeraldSAS/images/rooms/bedroom.jpg"><div
class="MuiGridroot MuiGrid-item MuiGrid-grid-xs-10 MuiGrid-grid-
md-6 MuiGridgrid-1g-5 marketing-text marketing-text-vertical-
center"><h2 class="MuiTypography-root MuiTypography-h2 bottom-
margin-
1"><b>Explore Your New Bedroom</b></h2><h5
class="MuiTypographyroot MuiTypography-h5 bottom-margin-2">Sleep
in luxury with all new furniture, lighting, and decor that fit
any bedroom style.</h5><a href="/bedroom"><button
class="marketing-button primary" tabindex="0" type="text"><span
class="MuiButtonlabel">Shop Bedroom</span><span
class="MuiTouchRippleroot"></span></button></a></div></div>
c. URL: /bedroom 8. Save > Close
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|Step 3 - Create Home Hero Web Activity
1. Select Activities from left menu list
2. File > New > Web Activity > Content Recommendation > OK
3. Select Starting Point on workspace
a. Name: Home Hero Image
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4. Select E-Marketing Spot on workspace
a. Enter “*” in search box and click ‘Find and Add”
b. From list on right, drag over “Home Hero” to the selection area
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5. Select Recommended Content on workspace
a. Enter “” in search box and click ‘Find and Add”
b. From list on right, drag over “HomeHeroContent” to the selection area
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6. Drag Branch icon from tool panel to area between E-Marketing Spot and Recommended
Content
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7. Select Branch on workspace
a. Name: Home Hero Personalization
b. Paths: Bedroom, General
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8. Select Recommend Content from Bedroom Branch on workspace
a. Click on HomeHeroContent listed in the Content box and click the “X” next to the ‘Find
and Add” button to remove it
b. Enter “*” in search box and click ‘Find and Add”
c. From list on right, drag over “HomeHeroContent-Bedroom” to the selection area
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9. Drag Cart icon from tool panel to the Bedroom branch right before the Recommended Content
icon
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10. Select Cart from Bedroom Branch on workspace

a. Shopping Cart Contents: Catalog Entries from Specific Categories

b. Target Customers: Who have catalog entries from any of the following categories and

satisfy the following conditions
c. Categories

i. Enter “*” in search box and click ‘Find and Add”

ii. From list on right, drag over “Beds” and “Dressers” to the selection

area d. Save
e. Edit > Activate
Close
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Step 5 - Modify Home Hero Web Activity

1. Select Activities from left menu list

2. Select “Home Recommended products”

3. Edit > Deactivate

4. Double click on “Home recommended products” to open activity

5. Drag Branch icon from tool panel to area between E-Marketing Spot and Recommended
Catalog Entry
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Select Branch on workspace
a. Name: Home Hero Personalization
b. Paths: Bedroom, General
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Drag Cart icon from tool panel to the Bedroom branch right before the Recommended

Catalog Entry icon
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Select Cart from Bedroom Branch on workspace
a. Shopping Cart Contents: Catalog Entries from Specific Categories
b. Target Customers: Who have catalog entries from any of the following categories and
satisfy the following conditions
c. Categories
i. Enter “*” in search box and click ‘Find and Add”
ii. From list on right, drag over “Beds” and “Dressers” to the selection area
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Select Recommend Catalog Entry from Bedroom Branch on workspace

a. Select all entries listed in the catalog entries box
b. Click the “X” next to the ‘Find and Add” button to remove it
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Add Bedroom products

b. Within the search box, enter and add the following products

i. BD-BEDS-0001 ii. BD-BEDS-0004

iii. BD-DRSS-0003 iv.
BD-DRSS-0002
v. BD-BEDS-0003

c. Save

d. Edit > Activate

e. Close
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|Step 6 - Review Website Personalization

Open up Emerald Storefront from the browser tab or from the SoFy Solution Console link
Review the current home hero image and recommended products

Go to Bedroom > Dressers

Select any item

Add to cart > View full cart

Return to Home Page and review changes to the Home Hero and Recommended Products
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\Step 7 — Demonstrate APl Capabilities

1. Open Postman
2. Import Environment JSON into the workspace
a. Select Environments > Import
b. Click “Upload Files” and select the “HCL Commerce SoFy Demo 1 - Environment.json”
or drag file into the window
c. Click Import

Home Workspaces Reports Explore
2 HCL Commerce SoFy Demo New  Import
N * /

2. Click Import

Globals

[E]

Environments

= \ You don't have any

. environments.
1. Click Environments

ment is a set of variables
that allows you to switch the context

f your requests

O

Create a new Environment

3. Update “bda-hostname” variable
a. Click on “HCL Commerce SoFy Demo 1 Environment”
b. Update the current value of “bda-hostname” by replacing the * values with the number
shown on your SoFy Solutions Console
c. Click Persist All
d. Click Save



Home  Workspaces Reports Explore ) Sea t 2y , Invite & @ L Q Upgrade

A HCL Commerce SoFy Demo New  Import (5] HCL Commerce S.
B 4. Click Save
(a T HCL Commerce SoFy Demo 1 Environment /A Share
Globals VARIABLE INITIAL VALUE CURRENT VALUE o00 Persist All Reset All
bda-hostname commerce-preview.sbx****play.sof... commerce-preview.sbx****play.sofy.dev
HCL Commerce SoFy Demo 1 Environment
@ storeld n n 7 .
= @ 3. Click Persist All
nnnnnnnnn s WCToken 47002%2CKZJdIbaa%2BZfBVcPAjX...  47002%2CKZJdIbaa%2BZfBVERA|XSIAYBMMO22tGRWIDGEGO0IKUe% 2BCTZPKO7LGYbWB.
WCTrustedToken 47002%2CjkVOR2vBhFUFWodcgdf...  47002%2CjkVOR2vBhFuF WodcgNdjmiugZo%2FAHUUWdYLKZiRs4A%3D
port-number 443 443
= i i 2. Replace * with value from
& 1. Click on Environment®g prosuctsk BD-BEDS-0001-0001 B8D-BEDS-0001-0001 :
Solution Console
eSpotName Home_ProductRec Home_ProductRec
orderld
{{adminid}} wesadmin wesadmin
{{adminpass}} wesladmin wesladmin

4. Import API Collection into the workspace
a. Select Collections > Import
b. Click “Upload Files” and select the “HCL Commerce SoFy Demo 1 - API
Collection.json” or drag file into the window
c. Click Import

Home Workspaces v Reports Explore
2 HCL Commerce SoFy Demo New  Import +

S +[= 000
Collections 2. Click Import

O
oo
APls
E ’.
R OTTEn You don’t have any

1. Click colle€ctions

= Collections let you group related
SELAY requests, making them easier to
access and run
Montters Create a new Collection

@

5. Run API Collection
a. From the collections area, click “HCL Commerce SoFy Demo 1 - Personalized
Shopping Experience” to expand APls
b. On the right side, click on “No Environment” and select “HCL Commerce Sofy Demo 1
Environment” from the dropdown menu



<o 2 Invite ® @ 0 Q‘ Upgrade v

No Environment X A~ (o

No Environment B

HCL Commerce SoFy Demo 1...

;:.Click Dropdown

Cookies <>

2. Select Environment®
DESCRIPTION 000 Bulk Edit

c. Select “Begin Guest Shopper Session” API > Click “Send” > Verify results
i. Call will return data to confirm a session has been established

= = Begin Guest Shopper Session v
v HCL Commerce SoFy Demo 1 - Person.
Begin Guest Shopper Session POST v https:// /wcs/resources/store/ /guestidentity?langld=-1
GE ault E-Marketing Spot ... )
Params ® Authorization Headers (9) Body Pre-request Script ests @ Settings Cookies
Add (Qalifying Item To Cart
Query Params
GET P&sonalized E-Marketing ...
KEY VALUE DESCRIPTION oo Bulk Edit
lang -1 :
angla 2. Click Send

1. Select API

3. Verify Results

Body Cookies Headers Test Results @ Status: 201 Created Time: 884ms Size: 8758  Save Response v
Pretty Raw Preview Visualize JSON v = mQ
1 q I
2 “"personalizationID": "1615485755654-6",
3 “resourceName": "guestidentity",
4 "WCToken":

"7%2CnePp4spo970%2F tRvvHCQEe02NCPrq%2F0QOMG3Ry0BIkMiwBeV2LQj kgd LOAD1Yxq56GtPnhNAXEJhAVPPSNZ6VaV98UZ8ZIES%2Fn2acZ0QdGFRZsv
DD3D0z0Z4uy28%2F0fjb2U1rMDafRN2RgSSeN86at f fmMMs Lpgmj%2BWShpKdwQys%2F88NMY%2Bt3YQVu5UHXx17JEVATc@7nhnoyV72mL7TwSQtBx2bH8QyG
6YvtIIcFi07Ca93pedjbqLOKp3A0V1gFP",

5 “userId": "7*,
6 "WCTrustedToken": “7%2CP9s6s\kyXdh62SLILcIEGe5ZDa%2F L16IhB%2BUfqHDAViQ%3D"
7 ¥ |

d. Select “GET Default E-marketing Spot Data” API > Click “Send” > Verify results
i. Call will return a listing of the default recommend products shown on the home

page



t = GET Default E-Marketing Spot Data v
v HCL Commerce SoFy Demo 1 - Person.
Begin Guest Shopper Session GET v https:// /wes/resources/store/11/espot/Home_ProductRec/type/MARKETING Send v
GET Default E-Marketing Spot .
Params Authorization @ Headers (11) Body Pre-request Script Tests et Cookies
Add Qualif tem To Cart
Query Params
GET Personfized E-Marketing ...
KEY VALUE DESCRIPTION eco  Bulk Edit
1. Select API 2. Click Send
3. Verify Results
Body Cookies (1 Headers ) Test Results tu: Time: 470 ms  Size: 1317 KB Save Response v
Pretty Raw Preview Visualize JSON v = mQ
1A
2 “MarketingSpotData": [
3 {
4 “nextTimeLimit": “-1",
5 “marketingSpotIdentifier": "13014",
6 “behavior": "1",
7 “eSpotName": "Home_ProductRec",
8 "baseMarketingSpotActivityData": [
9 {
10 "baseMarketingSpotActivityName": "Stonehenge UltraCozy Single Sofa",
11 “productId": "14033",
12 "description": [
13
14 "longDescription”: "The sofa has a short back rest but a long width to get lazy while sitting lazy.
With a matte fabric finish and a soft center, this is the perfect sofa to indulge someone to get
lazy and stay back.",

e. Select “Add Qualifying ltem to Cart” API > Click “Send” > Verify results
i. Call will return data confirming that an item has been added to the cart

t| = Add Qualifying Item To Cart v
v HCL Commerce SoFy Demo 1 - Person
Seqin Guest Shapper Session posT v hupsi) e Jcartziangid=-1
GET Default E-Marketing Spot ... X
Params ® Authorizat Headers (12) Body @ Pre-request Script Sis @ Settings Cookies
Add Qualifying Item To Cart
Query Params
GET PergliNlized E-Marketing
KEY VALUE DESCRIPTION o0 Bulk Edit
langld -1
1. Select API .
2. Click Send

3. Verify Results

Body Cookies Head Test R & 201 Created Time: 713 ms Size: 348 B Save Response v
Pretty Raw Preview valiz m Q
1 o
2 “orderId": "7112376",
3 “orderItem": [
! {
5 “orderItemId": “10014"
6 }
1,
8 “resourceName": “cart"
9 }

f. Select “GET Personalized E-marketing Spot Data” API > Click “Send” > Verify results
i. Call will return a listing of the personalized recommend products shown on the
home page when an item from a bedroom subcategory is in the cart
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v HCL Commerce SoFy Demo 1 - Person...
Begin Guest Shopper Session
GET GET Default E-Marketing Spot ...
Add Qualifying Item To Cart
GET GET Personalized E-Marketing ...

1. Select API

Experience / GET E Spot Data v e 7 E

o HCL Commerce SoFy Demo 1 - Personalized
GET v https://{{bda-hostr :{{port-number 11/espot/ | yp! TING
Params Authorization @ Headers (11) Body Pre-request Script Tests Settings Cookies
Query Params
VALUE DESCRIPTION oo Bulk Edit

KEY

Body Cookies (1) Headers (11)

2. Click Send

3. Verify Results

Test Results

€ Status: 200 OK Time: 257 ms Size: 665KB  Save Response v/

mQ

Pretty Raw Preview Visualize JSON v
1o
2 “MarketingSpotData": [
3
4 “nextTimeLimit": "-1'
5 "marketingSpotIdentifie: "13014",
6 "behavior": "1",
7 "eSpotName": "Home_ProductRec",
8 "baseMarketingSpotActivityData": [
9
10 "baseMarketingSpotActivityName": "Twin Bunk Bed",
11 "productId": "14266",
12 “description": [
13 {
14 "longDescriptiol Place this durable wooden bunk bed into your children's bedroom to provide

plenty of space-saving sleeping area. Included are safety features such as rails and guides to
ensure that vour children aet a aood. safe niaht's sleep. Fits standard twin mattresses. not




